Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Errors After Solution Generation
GodofThunder
#1 Posted : Tuesday, June 5, 2018 2:59:33 PM(UTC)


Hello,

I'm using Xomega 7.7.3 with Visual Studio 15.7.


I've tried generating several Xomega SPA Web Solution solutions. :-)

I don't make any changes. I just try to compile immediately after the solution is generated.

I always seem to get the following errors at compile time:

Severity Code Description Project File Line Suppression State
Error TS2307 (TS) Cannot find module 'Views/MainMenu'. C:\Users\GoT\Source\repos\MyProject2\MyProject2\MyProject2.Client.Spa (tsconfig or jsconfig project) C:\Users\GoT\Source\repos\MyProject2\MyProject2\MyProject2.Client.Spa\shell.ts 1 Active
Error CS0234 The type or namespace name 'Entities' does not exist in the namespace 'MyProject2.Services' (are you missing an assembly reference?) MyProject2.Services.Rest C:\Users\GoT\Source\repos\MyProject2\MyProject2\MyProject2.Services.Rest\App_Start\AppServicesInit.cs 1 Active
Error Build:Cannot find module 'Views/MainMenu'. MyProject2.Client.Spa C:\Users\GoT\Source\repos\MyProject2\MyProject2\MyProject2.Client.Spa\shell.ts 1
Error Build:Cannot find module 'Views/MainMenu'. MyProject2.Client.Spa C:\Users\GoT\Source\repos\MyProject2\MyProject2\MyProject2.Client.Spa\shell.ts 1
Error TS2307 (TS) Cannot find module 'Views/MainMenu'. C:\Users\GoT\Source\repos\MyProject2\MyProject2\MyProject2.Client.Spa (tsconfig or jsconfig project) C:\Users\GoT\Source\repos\MyProject2\MyProject2\MyProject2.Client.Spa\shell.ts 1 Active

Could you please advise?

Thanks,

GoT
xomega
#2 Posted : Tuesday, June 5, 2018 4:08:00 PM(UTC)
xomega



Hi GoT,

Thanks for your interest in Xomega. Our solution templates contain preconfigured code that helps you hit the ground running, and create a complete application with as little coding as possible.

That's why they do not compile immediately after creation, but you can still build the Model project first, which would generate the artifacts that the code depends upon, such as the MainMenu, and then you should be able to build the (empty) solution.

The Model project is not built when you build the entire solution, since you only want to build it after you make model changes. So you have to build the Model project explicitly via the context menu or the Build menu when that project is selected.

Please let me know if this works for you.
GodofThunder
#3 Posted : Tuesday, June 5, 2018 4:24:48 PM(UTC)


It worked like a champ!

Thanks,

GoT
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Copyright © 2009-2023 Xomega.Net. All rights reserved.