Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

After Generation Home Only Menu Item
GodofThunder
#1 Posted : Tuesday, June 26, 2018 3:41:45 PM(UTC)


Hello,

I've been able to generate the code without issue now. I have several views.

What I see is the Home menu with no other menu items...

I'm using the SPA Project.

Could you please advise?

Thanks Again,

GoT
xomega
#2 Posted : Tuesday, June 26, 2018 5:59:18 PM(UTC)
xomega



We are glad that you are making progress, and will be happy to help you.

Xomega SPA Views generator builds a menu from the views that are not marked with "child" attribute, and groups them by the Xomega module they are defined in. This is output by default to the Views\MainMenu.ts file under the Spa project, which is configurable in the generator's properties.

Do you see anything generated in that file?

(Btw, if you don't like the way the main menu is generated, you can always create your own similar structure, and update the shell.ts to use that instead.)
GodofThunder
#3 Posted : Wednesday, June 27, 2018 3:26:27 PM(UTC)


Hello,

I tried a variety of ways to regenerate the files...

The file still has the following...

//---------------------------------------------------------------------------------------------
// This file was AUTO-GENERATED by "SPA Views" Xomega.Net generator.
//
// Manual CHANGES to this file WILL BE LOST when the code is regenerated.
//---------------------------------------------------------------------------------------------

export var MainMenu = [
];

One thing that would be a massive help would be adding a "ReGenerate Everything" menu somewhere... That regenerates all the layers. I really don't mind if it takes 10 minutes. The main thing is everything is regenerated without any guesswork.

Thanks,

GoT
xomega
#4 Posted : Wednesday, June 27, 2018 4:19:16 PM(UTC)
xomega



Thanks for getting back to us on this.

As a matter of fact, if you right-click on the .Model project, and select Build, this will rerun all the generators that are included in the model build (via the corresponding generator property), which is basically that "ReGenerate Everything" option you were looking for. You should see all the generators being run in the Output window.

Now, on the issue with the main menu, it looks like the <module> elements, where your views are defined in the model may have no "name" attribute, which makes them not being generated for the main menu, since it's organized by the modules.

As a workaround, I'd recommend adding the name to your modules, which would also help you keep the generated views, data objects and other artifacts organized. But if you really don't want the named module, you can generate the main menu, revert back to no-name, and use the generated menu as custom code in a separate .ts file.

On our end, we can update the generator to place all such views from the default module under some fixed menu, such as 'Views'.

Please let us know if this works for you.
xomega
#5 Posted : Friday, August 10, 2018 8:36:57 AM(UTC)
xomega



The issue with the generated menu options for SPA and WPF views that don't have a module name has been resolved in the new versions 7.7.4 and 6.7.4 for VS2017 and VS2015 respectively. Now the generated menus for such views will be under the default Views menu.

Please download the updated version, and let us know if it works for you.
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Copyright © 2009-2022 Xomega.Net. All rights reserved.