Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

How to setup database connection
xomega
#1 Posted : Wednesday, July 25, 2012 4:44:04 PM(UTC)
xomega



The following steps allow you to set up a database connection either for all generators or for a specific generator.
  1. Open the database connection editor dialog on the Properties tab of the model project or of a specific generator.
  2. On the Connection tab click the Configure button to build the connection string. A Data Link Properties dialog will appear.
  3. On the Provider tab select the driver, e.g. SQL Native Client. Set the server name, credentials and the initial catalog on the Connection tab. Test the connection and click OK.
  4. On the Database Connection Configuration dialog click Next to select tables to exclude. If the operation times out, you can increase the timeout on this page.
  5. On the Excluded Tables tab select the tables that you want to exclude from the model. This will prevent those table from being imported into the model and the database update script will not consider them as deleted.
  6. Click Next and review the summary of your configuration. If working with a specific generator, you will have an option to save it as a project default configuration.
  7. Click Finish to save the database connection setup.
oulkabir
#2 Posted : Tuesday, October 27, 2015 4:02:12 AM(UTC)


Hello,
Please I can not configure the connection. When I try to create my database connection through the confogurateur I have this error message "input string Was not in a correct format" I have a SQL Server 2008 R2

My connetion string is :Provider=SQLNCLI10;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=Northwind;Data Source=(local);
Thank you
xomega
#3 Posted : Tuesday, October 27, 2015 4:26:48 AM(UTC)
xomega



Hi. Is this error shown when you press Next on the Connection tab of the Database Connection Configuration dialog? Did you configure the connection string through the Data Link Properties dialog, and did it work if you press Test Connection there?
oulkabir
#4 Posted : Tuesday, October 27, 2015 4:32:51 AM(UTC)



Thanks for your feedback,

or this message appears when I click Next.

I set the connection string and it works when I test but I can not go to the next step
xomega
#5 Posted : Tuesday, October 27, 2015 4:47:11 AM(UTC)
xomega



Your connection string looks fine. Do you have anything in the Timeout (sec) text box on that tab? Can you put some integer value like 60 in there?
Pekka Kauppinen
#6 Posted : Wednesday, November 11, 2015 9:59:16 PM(UTC)


I have same problem. My database's culture is Finland "fi-Fi". Maybe this is problem?
xomega
#7 Posted : Thursday, November 12, 2015 4:13:27 AM(UTC)
xomega



Thanks for reporting your problem. Yes, the DB culture may be the issue. Could you please run the following in your database and post the result:
select SERVERPROPERTY('ProductVersion')

Also, if you have the same culture for the database and your system, then can you try installing the previous version 5.6.0 and see if it works for you?
Pekka Kauppinen
#8 Posted : Thursday, November 12, 2015 7:35:40 AM(UTC)


Answer that query is: 11.0.9231.178 Server is Azure-server. My Pc is Win10, Visual Studio 2015 and Xomega.net 6.6.1

My other Pc is Win10, Visual Studio 2013 and Xomega.net 5.6.1. This give different error message: "Invalid object name 'fn_listextendedproperty'"

Where I find and download earlier versions?

xomega
#9 Posted : Thursday, November 12, 2015 7:26:40 PM(UTC)
xomega



This is strange, since this error is supposed to be fixed in both 5.6.1 and 6.6.1 releases. I don't see it in 6.6.1 when I set my local regional settings to Finland, and your SQL Server version looks fine with a dot (.) as a decimal separator. Do you still see this error if you change the format on your Region and Language settings to English (United States), or more specifically when you change the Decimal symbol to a dot?

As for the other issue with fn_listextendedproperty function, it appears that unfortunately it is not supported by the Azure SQL Server. We will fix it shortly and will publish a patch release for that, but for now you can point to a local or on-premise database. Sorry about this.
Pekka Kauppinen
#10 Posted : Thursday, November 12, 2015 10:14:03 PM(UTC)


I changed Region and Language settings to English (United States), then error message is "Invalid object name 'fn_listextendedproperty'".

And, then I changed regional settings back to Finland, the error message remain "Invalid object name 'fn_listextendedproperty'" ?????!!!!

So I will wait patch for Azure SQL server. Local SQL server is not possible for me.

PC: Win10, Visual Studio 2015 and Xomega.net 6.6.1

Very thanks! -Pekka-



xomega
#11 Posted : Friday, December 18, 2015 6:08:45 PM(UTC)
xomega



Hi Pekka -

It looks like Azure now has a SQL Server version 12, which supports function fn_listextendedproperty, so that you'd be able to import a Xomega model from such a database. Is it feasible for you to upgrade to this SQL server version on Azure?

Thanks,
Xomega Team
Pekka Kauppinen
#12 Posted : Sunday, December 20, 2015 9:22:09 AM(UTC)


Fine! It Works now!!

Thanks!

-Pekka-
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Copyright © 2009-2022 Xomega.Net. All rights reserved.